Форум администраторов игровых серверов

Форум администраторов игровых серверов (https://forum.zone-game.info/TT.php)
-   Создание сервера (https://forum.zone-game.info/forumdisplay.php?f=133)
-   -   небольшой вопрос о совместимости сервера с клиентом (https://forum.zone-game.info/showthread.php?t=19368)

frizyy 17.04.2012 09:34

небольшой вопрос о совместимости сервера с клиентом
 
у нас всети стоит сервер бнет на 1.24 версию варика, возможно ли его поставить на версию 1.26 или надо отдельный сервер на новую версию?

Array 18.04.2012 14:43

Re: небольшой вопрос о совместимости сервера с клиентом
 
В versioncheck.conf добавить подобные записи:
Код:

# Warcraft III - TFT (Expansion) 1.22a
# Note: this version check is sent in both FT and ROC mode
"A=3845581634 B=880823580 C=1363937103 4 A=A-S B=B-C C=C-A A=A-B" \
 IX86ver1.mpq \
 IX86 \
 W3XP \
 "war3.exe 06/27/08 00:01:35 471040" \
 0x00000016 \
 1.22.0.184 \
 0x909998db \
 W3XP_122A

И должно заработать. Только что будет с игроками, у которых разные версии =\ .

frizyy 18.04.2012 16:45

Re: небольшой вопрос о совместимости сервера с клиентом
 
Цитата:

Сообщение от "E=Array (Сообщение 179643)
В versioncheck.conf добавить подобные записи:
Код:

# Warcraft III - TFT (Expansion) 1.22a
# Note: this version check is sent in both FT and ROC mode
"A=3845581634 B=880823580 C=1363937103 4 A=A-S B=B-C C=C-A A=A-B" \
 IX86ver1.mpq \
 IX86 \
 W3XP \
 "war3.exe 06/27/08 00:01:35 471040" \
 0x00000016 \
 1.22.0.184 \
 0x909998db \
 W3XP_122A

И должно заработать. Только что будет с игроками, у которых разные версии =\ .

т.е. ты хочешь сказать что если сервер бнет старой версии(1.24) вполне пойдёт на новую версию вар крафта(1.26)?

что будет с игроками у которых разные версии? ты хочешь сказать что на сервер смогут зайти и с 1.24 и с 1.26? это реально?
при заходе на бнет будет же писать что клиент не соответствует версии разве не так?

почему в коде присутствуют записи на 1.22 версию? или это только пример?
не думаю что всё так просто..

Array 18.04.2012 17:29

Re: небольшой вопрос о совместимости сервера с клиентом
 
Если в PvPGN реализована поддержка 1.26, то после добавления в versioncheck этой версии, не будет писать "несоответствие версии".

И зайти должно быть можно с разных, другое дело как они между собой поладят.

frizyy 18.04.2012 17:37

Re: небольшой вопрос о совместимости сервера с клиентом
 
Цитата:

Сообщение от Array (Сообщение 179691)
Если в PvPGN реализована поддержка 1.26, то после добавления в versioncheck этой версии, не будет писать "несоответствие версии".

И зайти должно быть можно с разных, другое дело как они между собой поладят.

очевидно не очень будет совместимость т.к. патчи то не просто так делали, а есть всякие фиксы.

а то так бы многие игровые платформы так и делали типа айкапа..

ладно проверим этот способ, если что будем ставить новый сервер

и кстати если на старом сервере стоял хостбот то и на новый он пойдёт?


Текущее время: 23:45. Часовой пояс GMT +3.

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd. Перевод: zCarot