Форум администраторов игровых серверов

Форум администраторов игровых серверов (https://forum.zone-game.info/TT.php)
-   Тех-документация (https://forum.zone-game.info/forumdisplay.php?f=41)
-   -   [Мануал] Работа с Eclipse Classic (полный гайд) и SVN на примере L2Emu (https://forum.zone-game.info/showthread.php?t=2334)

DarkLoki 22.11.2008 14:03

[Мануал] Работа с Eclipse Classic (полный гайд) и SVN на примере L2Emu
 
Гайд по работе с Eclipse:
Что понадобится:
- Java jdk 1.6 или более новая (http://www.sun.com)
- Eclipse Classic 3.1 или более новый (http://www.eclipse.org) или же если у вас стоит 64 битная ява, то Eclipse 3.4M6a или выше
- maven 2.0.6 или выше (http://www.apache.org)

Пункт 1:

1) Инсталлим Java
2) Извлекаем Eclipse
2.1) Скачиваем и извлекаем Maven.


3)- Запустите Eclipse и укажите путь, где будут храниться ваши сборки (например: C:\Workspace) и ставим галочку чтоб сделать ее по умолчанию

4)- Идем Help----> Software updates---> Search new features to install, жмем на New Remote Site и вводим:

Name: subeclipse
URL: http://subclipse.tigris.org/update

- И еще разок New Remote Site и вводим:

Name: Mylyn
URL:
http://download.eclipse.org/tools/mylyn/update/e3.3 - (для Eclipse 3.3)
http://download.eclipse.org/tools/mylyn/update/e3.4 - (для Eclipse 3.4M)

6)- Жмем ok и finish, выбираем subeclipse и mylyn для инсталляции и жмем next, принимаем условия, next и finish.

7)- Ждем пока Eclipse скачает дополнение и соглашаемся на перезагрузку программы.

8)- Идем в Window - Preferences - Java - Installed JREs - Search - идем в папку с Java и выбираем папочку jdk... и жмем Ок, далее ставим галочку напротив jdk... и жмем Ок


Пункт 2:

Переходим к настройке Java

Пуск.....> Панель управления.....> Система........> Дополнительно.........> Переменные среды....> создаем новый параметр

Имя: JAVA_HOME
Значение: путь к Java JDK (без папки bin)
например: C:\Program Files\Java\jdk1.6.0\

Жмем Ок и закрываем окно.

Пуск........... Выполнить............ cmd

Переходим в папку с Maven'ом (в командной строке)

например: cd c:/maven2/bin

Далее прописаваем "mvn" (без ковычек) и вы увидите сообщение "build failure" (перед этим можете вместо "mvn" прописать "mvn install" - в данном случае в будущем не придется ждать пока скачаются основные компоненты мавена) - это нормально, закрываем командную строку


Пункт 3:

1) Открываем Eclipse - Press on help----> software updates---> Search new features to install, жмем на New Remote Site и вводим:

Name: m2plugin
URL: http://m2eclipse.sonatype.org/update/

Принимаем все соглашения и условия, соглашаемся на перезагрузку программы.

После жмем Window--- show view--- other----- svn repository (можно в верхнем окошке ввести svn и он высветит svn repository, чтобы не искать самим)

Правой кнопкой мышы на окошке Svn Repository:

New ---> repository location:

URL: ссылки брать тут

2)- заходим в Trunk, правой кнопкой по папке (геймсервер, потом логин и потом датапак (порядок любой) Check out As Project и скачиваем исходники

3)- после чего тыкаем правой кнопкой мыши по скаченной папке с геймсервером (в Eclipse) -> Maven -> Enable что-то-там и дожидаемся скачки исходников, требуемых для гейма, затем проделываем тоже самое с логином.


Пункт 4 (финальный):

После того как скачали все что нужно делаем следующее:
* Правой кнопкой по папке с Login Server -> Run as... -> Maven build...
* goals: clean assembly:assembly
* Click Add -> name: maven.test.skip, value: true -> ok -> apply -> run

Для копиляции геймсервера проделываем все тоже самое, но выбираем Game Server.


*Для компиляции датапака жмем на стрелочку перед датапаком в окне Package Exp...правой кнопкой по файлу build.xml -> Run as -> Ant build

Собранные части сервера будут расположены здесь: (путь к папке со сборками (который указали при первом запуске программы)\(папка соответствующая логину/гейму/датапаку)\target (для датапака папка build) и тута найдете архив

P.S: чтобы обновить в эклипсе жмем правой кнопкой мыши на проекте, который хотите обновить (логин, гейм или датапак) -> Replace With -> Latest from repository и ждем пока обновятся определенные файлы

ОШИБКИ С ФАЙЛОМ POM.XML при обновлении исходников мавена или копиляции МОЖНО ИГНОРИРОВАТЬ!!!

Asd_Arm 05.12.2008 20:50

Ответ: [Мануал] Работа с Eclipse Classic (полный гайд) и SVN на примере L2Emu
 
Цитата:

3)- после чего тыкаем правой кнопкой мыши по скаченной папке с геймсервером (в Eclipse) -> Maven -> Enable что-то-там и дожидаемся скачки исходников, требуемых для гейма, затем проделываем тоже самое с логином.


Пункт 4 (финальный):

После того как скачали все что нужно делаем следующее:
* Правой кнопкой по папке с Login Server -> Run as... -> Maven build...
что-то я не нашол упоминания Мавена в Эклипсе

PROGRAMMATOR 05.12.2008 21:11

Ответ: [Мануал] Работа с Eclipse Classic (полный гайд) и SVN на примере L2Emu
 
Теперь "внимательно" перечитываем пункт 2 и 3. Желательно попытаться понять что там написано.

Asd_Arm 06.12.2008 15:36

Цитата:

Сообщение от DarkLoki (Сообщение 23366)
Пункт 3:

1) Открываем Eclipse - Press on help----> software updates---> Search new features to install, жмем на New Remote Site и вводим:

Name: m2plugin
URL: http://m2eclipse.sonatype.org/update/

Принимаем все соглашения и условия, соглашаемся на перезагрузку программы.

обновить не выходит пишет такое
Cannot complite the request.See the details

Добавлено через 13 минут
eclipse-SDK-3.4.1-win32 этот стоит у мну

прошу не игнорировать

PROGRAMMATOR 09.12.2008 14:42

Ответ: [Мануал] Работа с Eclipse Classic (полный гайд) и SVN на примере L2Emu
 
Цитата:

Сообщение от Asd_Arm (Сообщение 24216)
прошу не игнорировать

Да не игнорируют, просто ни у кого такой проблемы небыло. Я уже 100 раз ставил Eclipse и обновлял его плагины, все отлично. Где то Вы накосячили (например установили плагин не под вашу версию), удалите Eclipse, скачайте новый, повторите действия по мануалу.

Asd_Arm 09.12.2008 19:41

Ответ: [Мануал] Работа с Eclipse Classic (полный гайд) и SVN на примере L2Emu
 
Eclipse Classic 3.4.1 вот этот я скачал на сайте указанном в мануале другого нет
maven-2.0.9 так-же как и эклипс там другого нету на сайте

Добавлено через 5 минут
2) Извлекаем Eclipse
2.1) Скачиваем и извлекаем Maven.


и ещё вопрос ногами не бить если туплю просто я навичёк есть ли требование по извлечению мавена или его извлекать куда угодно можно

Stema 20.12.2008 00:40

Ответ: [Мануал] Работа с Eclipse Classic (полный гайд) и SVN на примере L2Emu
 
4)- Идем Help----> Software updates---> Search new features to install, жмем на New Remote Site и вводим:

Такого нет :( Есть только Help-Software Updates... и вылазит окошко.. Жму Aviable softwar (вкладка). Далее кнопочку Add Site... и там добавляю ссылку ссылки дл обновления. После по ним правой кнопкой Install, и все устанавливалось ок.. А вот с

Цитата:

1) Открываем Eclipse - Press on help----> software updates---> Search new features to install, жмем на New Remote Site и вводим:

Name: m2plugin
URL: http://m2eclipse.sonatype.org/update/
пишет Сannot complete the request... Generating Details

Цитата:

Cannot complete the request. See the details.
Unsatisfied dependency: [org.maven.ide.eclipse.ajdt.feature.feature.group 0.9.6.20080905-0917] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ajdt.feature.group/1.5.0
Unsatisfied dependency: [org.maven.ide.eclipse.editor.feature.feature.group 0.9.6.20080905-0917] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.draw2d/[3.4.0.v20080529,3.4.0.v20080529]
Unsatisfied dependency: [org.maven.ide.eclipse.ajdt 0.9.6.20080905-0917] requiredCapability: osgi.bundle/org.eclipse.ajdt.core/1.5.0
Unsatisfied dependency: [org.maven.ide.eclipse.editor.feature.feature.group 0.9.6.20080905-0917] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.draw2d/[3.4.0.v20080529,3.4.0.v20080529]
Unsatisfied dependency: [org.maven.ide.eclipse.feature.feature.group 0.9.6.20080905-0917] requiredCapability: org.eclipse.equinox.p2.iu/org.maven.ide.components.maven_model_edit/[1.0.0.20080905-0917,1.0.0.20080905-0917]
Unsatisfied dependency: [org.maven.ide.eclipse.ajdt 0.9.6.20080905-0917] requiredCapability: osgi.bundle/org.eclipse.ajdt.core/1.5.0
Unsatisfied dependency: [org.maven.ide.eclipse.ajdt.feature.feature.group 0.9.6.20080905-0917] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ajdt.feature.group/1.5.0
Unsatisfied dependency: [org.maven.ide.eclipse.ajdt.feature.feature.group 0.9.6.20080905-0917] requiredCapability: org.eclipse.equinox.p2.iu/org.maven.ide.eclipse.ajdt/[0.9.6.20080905-0917,0.9.6.20080905-0917]
Unsatisfied dependency: [org.maven.ide.eclipse.ajdt.feature.feature.group 0.9.6.20080905-0917] requiredCapability: org.eclipse.equinox.p2.iu/org.maven.ide.eclipse.feature.feature.group/0.0.0
Unsatisfied dependency: [org.maven.ide.eclipse.wtp.feature.feature.group 0.9.6.20080905-0917] requiredCapability: org.eclipse.equinox.p2.iu/org.maven.ide.eclipse.feature.feature.group/0.0.0
Как быть? Эклипс SDK 3.4.1 Build id: M20080911-1700

Спасибо.

SVKoT 30.12.2008 12:36

Ответ: [Мануал] Работа с Eclipse Classic (полный гайд) и SVN на примере L2Emu
 
http://m2eclipse.codehaus.org/update/ попробуй

AgentRus 30.12.2008 21:34

Ответ: [Мануал] Работа с Eclipse Classic (полный гайд) и SVN на примере L2Emu
 
Цитата:

Сообщение от DarkLoki (Сообщение 23366)
* goals: clean assembly:assembly

Вродебы установил всё правильно всё есть кроме этого(

Nastia 18.01.2009 13:04

Ответ: [Мануал] Работа с Eclipse Classic (полный гайд) и SVN на примере L2Emu
 
Мммм возник вопросик а как ревизию обновить то чтоб поновому исходник не перекачивать?....

vasill 18.01.2009 13:15

Ответ: [Мануал] Работа с Eclipse Classic (полный гайд) и SVN на примере L2Emu
 
Чтобы обновить в эклипсе жмем правой кнопкой мыши на проекте, который хотите обновить (логин, гейм или датапак) -> Replace With -> Latest from repository и ждем пока обновятся определенные файлы

stanleek 27.01.2009 00:30

Ответ: [Мануал] Работа с Eclipse Classic (полный гайд) и SVN на примере L2Emu
 
Те же ошибки при установке!

PROGRAMMATOR 02.02.2009 17:21

Ответ: [Мануал] Работа с Eclipse Classic (полный гайд) и SVN на примере L2Emu
 
stanleek, что значит те же? Где лог ошибки, где скрин ошибки? Еще подобный пост и заблокирую!

deri 03.02.2009 09:02

Ответ: [Мануал] Работа с Eclipse Classic (полный гайд) и SVN на примере L2Emu
 
Цитата:

Сообщение от Stema (Сообщение 24870)
4)- Идем Help----> Software updates---> Search new features to install, жмем на New Remote Site и вводим:

Такого нет :( Есть только Help-Software Updates... и вылазит окошко.. Жму Aviable softwar (вкладка). Далее кнопочку Add Site... и там добавляю ссылку ссылки дл обновления. После по ним правой кнопкой Install, и все устанавливалось ок.. А вот с



пишет Сannot complete the request... Generating Details



Как быть? Эклипс SDK 3.4.1 Build id: M20080911-1700

Спасибо.

У меня подобная проблема возникла. И соответственно интегрировать мавен в эклипс не удается. пробовал
Цитата:

http://m2eclipse.codehaus.org/update/ попробуй
не получилось тоже что тос ним... в остальном вопросов не возникло кроме этого пункта.
Если кто может подсказать как это решить, зараннее благодарю.

AgentRus 03.02.2009 18:09

Ответ: [Мануал] Работа с Eclipse Classic (полный гайд) и SVN на примере L2Emu
 
Цитата:

Сообщение от deri (Сообщение 27132)
У меня подобная проблема возникла. И соответственно интегрировать мавен в эклипс не удается. пробовал не получилось тоже что тос ним... в остальном вопросов не возникло кроме этого пункта.
Если кто может подсказать как это решить, зараннее благодарю.

у меня eclipse 3.4.1, и таже проблема

AgentRus 04.02.2009 20:28

Ответ: [Мануал] Работа с Eclipse Classic (полный гайд) и SVN на примере L2Emu
 
У меня получилось всё обновить вот от сюда http://m2eclipse.sonatype.org/update-dev/ обновилось всё кроме AJDT. Обьясните плиз правильно ли я сделал?

deri 04.02.2009 23:33

Ответ: [Мануал] Работа с Eclipse Classic (полный гайд) и SVN на примере L2Emu
 
программатор, только ты наверно можешь помочь с ответом на нашу проблему )
Вохможно у тебя более старая версия эклипса, и мы трое с этой бедой новички в компиляции серверов скачали новую измененную.., я напрмер эклипс видел только однажды за все время которое знаком с компами, и то издалека )

MewTwo 29.04.2009 16:04

Ответ: [Мануал] Работа с Eclipse Classic (полный гайд) и SVN на примере L2Emu
 
Подскажите что делать если команда cmd не запускаеться?

Morfez 09.06.2009 07:00

Ответ: [Мануал] Работа с Eclipse Classic (полный гайд) и SVN на примере L2Emu
 
Как все делать в новой версии? Таких пунктов нету?! у меня 3.4.2

Сообщение от Stema Посмотреть сообщение
4)- Идем Help----> Software updates---> Search new features to install, жмем на New Remote Site и вводим:

Такого нет Есть только Help-Software Updates... и вылазит окошко.. Жму Aviable softwar (вкладка). Далее кнопочку Add Site... и там добавляю ссылку ссылки дл обновления. После по ним правой кнопкой Install, и все устанавливалось ок.. А вот с



пишет Сannot complete the request... Generating Details



Как быть? Эклипс SDK 3.4.1 Build id: M20080911-1700

Спасибо.

nsux 16.08.2009 13:31

Ответ: [Мануал] Работа с Eclipse Classic (полный гайд) и SVN на примере L2Emu
 
Подскажите как сделать чтоб при загрузке файла *.dat в Эклипсе, абракадабра не вылазила....

Добавлено через 2 часа 6 минут
Блин, народ. Ну помогите

Добавлено через 4 часа 40 минут
Че не кто не знает чтоли???


Текущее время: 03:04. Часовой пояс GMT +3.

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd. Перевод: zCarot