Компиляция - Форум администраторов игровых серверов
Форум администраторов игровых серверов StormWall - Защита от DDos атак
Регистрация Мнения Справка Пользователи Календарь Все разделы прочитаны
Вернуться   Форум администраторов игровых серверов > MMO > Lineage II

Lineage II
Дискуссии на тему создания, настройки и обслуживания серверов Lineage 2. При поддержке: Премиум услуги по рекламе

Ответ
Опции темы
Непрочитано 20.02.2009, 14:40   #1
Пользователь

Автор темы (Топик Стартер) Компиляция

Пытаюсь скомпилировать сборку l2JFree 5185 ревизия, проблема такова:
компиляция начинаеться, создаёться папка target/clasess и начинают ити ошибки потипу таких
Цитата:
C:\L2JFree\l2jfree-core\src\main\java\com\l2jfree\gameserver\network\ serverpacke
ts\ExShowFortressMapInfo.java:[35,5] annotations are not supported in -source 1.
3
(use -source 5 or higher to enable annotations)
@Override

C:\L2JFree\l2jfree-core\src\main\java\com\l2jfree\gameserver\handler\ skillhandle
rs\FishingSkill.java:[34,47] annotations are not supported in -source 1.3
(use -source 5 or higher to enable annotations)
public void useSkill(L2Character activeChar, @SuppressWarnings("unused")


C:\L2JFree\l2jfree-core\src\main\java\com\l2jfree\gameserver\handler\ skillhandle
rs\FishingSkill.java:[36,9] variable-arity methods are not supported in -source
1.3
(use -source 5 or higher to enable variable-arity methods)
L2Object... targets)

C:\L2JFree\l2jfree-core\src\main\java\com\l2jfree\gameserver\network\ clientpacke
ts\RequestHennaItemInfo.java:[40,5] annotations are not supported in -source 1.3

(use -source 5 or higher to enable annotations)
@Override

C:\L2JFree\l2jfree-core\src\main\java\com\l2jfree\gameserver\network\ clientpacke
ts\Action.java:[34,2] annotations are not supported in -source 1.3
(use -source 5 or higher to enable annotations)
@SuppressWarnings("unused")

C:\L2JFree\l2jfree-core\src\main\java\com\l2jfree\gameserver\network\ serverpacke
ts\SiegeInfo.java:[52,2] annotations are not supported in -source 1.3
(use -source 5 or higher to enable annotations)
@Override

C:\L2JFree\l2jfree-core\src\main\java\com\l2jfree\gameserver\model\ac tor\instanc
e\L2SummonInstance.java:[43,18] generics are not supported in -source 1.3
(use -source 5 or higher to enable generics)
private Future<?> _summonConsumeTask;
Компилю как Zg-compilator так и maven ошибка одна и таже... в Файле Pom.xml все испрвил
NesH вне форума Ответить с цитированием
Непрочитано 20.02.2009, 15:36   #2
Пользователь

По умолчанию Ответ: Компиляция

найди эти строки во всех pom.xml и поставь вместо 1.3 => 1.6
Код:
      <plugin>
        <groupId>org.apache.maven.plugins</groupId>
        <artifactId>maven-compiler-plugin</artifactId>
        <configuration>
          <source>1.6</source>
          <target>1.6</target>
        </configuration>
      </plugin>
__________________
for(;Forum.getPostCount() < Integer.MAX_VALUE; Forum.writeNewPost()); | TERA Video | GamezTERA Emu
Aquanox вне форума Ответить с цитированием
Непрочитано 20.02.2009, 16:46   #3
Пользователь

Автор темы (Топик Стартер) Ответ: Компиляция

Цитата:
[INFO] Scanning for projects...
[INFO] Searching repository for plugin with prefix: 'assembly'.
WAGON_VERSION: 1.0-beta-2
[INFO] ------------------------------------------------------------------------
[INFO] Building Unnamed - l2jfree:l2jfree-core:jar:1.2.10
[INFO] task-segment: [assembly:assembly] (aggregator-style)
[INFO] ------------------------------------------------------------------------
[INFO] Preparing assembly:assembly
[INFO] ------------------------------------------------------------------------
[INFO] Building Unnamed - l2jfree:l2jfree-core:jar:1.2.10
[INFO] ------------------------------------------------------------------------
[INFO] [buildnumber:create {execution: default}]
[INFO] Checking for local modifications: skipped.
[INFO] Updating project files from SCM: skipped.
Provider message:
The svn command failed.
Command output:
"svn" не является внутренней или внешней
командой, исполняемой программой или пакетным файлом.

[INFO] ------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO] ------------------------------------------------------------------------
[INFO] Cannot get the revision information from the scm repository :
Error!

[INFO] ------------------------------------------------------------------------
[INFO] For more information, run Maven with the -e switch
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 2 seconds
[INFO] Finished at: Fri Feb 20 15:42:16 EET 2009
[INFO] Final Memory: 7M/14M
[INFO] ------------------------------------------------------------------------
Теперь вот такая Ошибка
Использую вот етот Свн TortoiseSVN-1.4.8.12137-win32-svn-1.4.6.msi
Строчку в Pom.xml удалил вот
<artifactId>buildnumber-maven-plugin</artifactId>
теперь так... Чтож делать..
NesH вне форума Ответить с цитированием
Ответ


Здесь присутствуют: 1 (пользователей: 0 , гостей: 1)
 
Опции темы

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.

Быстрый переход


© 2007–2022 «Форум администраторов игровых серверов»
Защита сайта от DDoS атак — StormWall
Работает на Булке неизвестной версии с переводом от zCarot
Текущее время: 21:41. Часовой пояс GMT +3.

Вверх