Debian Mysql - Форум администраторов игровых серверов
Форум администраторов игровых серверов StormWall - Защита от DDos атак
Регистрация Мнения Справка Пользователи Календарь Все разделы прочитаны
Вернуться   Форум администраторов игровых серверов > Полезное / Common > Операционные системы / Operating systems

Операционные системы / Operating systems
Форум на котором Вы сможете обсудить существующие операционные системы Unix, Windows, а так же получить помощь в установке, настройке, и обслуживании этих систем. Если не получается установить программу на вашу систему, пожалуйста, спрашивайте. При поддержке: Рейтинг серверов самых популярных online-игр

Ответ
Опции темы
Непрочитано 01.06.2012, 23:44   #1
Аватар для Shem
Пользователь

Автор темы (Топик Стартер) Debian Mysql

Всем доброе время суток, хочу задать вопрос по поводу Mysql.
Установил mysql, создал базу все вроде в порядке, а когда дошло дело до подключения к базе с другой машины, тут начались неполадки.
Создал пользователя 'test@%', дал ему все привилегии, добавил в iptables исключение порта 3306, открыл порт на самом роутере, закомментил строку bind-address 127.0.0.1 в my.cnf, а мне все равно выбивает вот такую ошибку при подключение к базе через другой компьютер:
"2003 - Can't connect to' MySQL server on "***.***.*.***'(10061)
Господа, что я упустил?
Shem вне форума Отправить сообщение для Shem с помощью ICQ Ответить с цитированием
Непрочитано 01.06.2012, 23:47   #2
Супергерой

По умолчанию Re: Debian Mysql

Shem, рестарт сервиса не упустил?)
Romka вне форума Ответить с цитированием
Сказали спасибо:
Непрочитано 01.06.2012, 23:50   #3
Аватар для Shem
Пользователь

Автор темы (Топик Стартер) Re: Debian Mysql

Цитата:
Сообщение от RomkaCW Посмотреть сообщение
Shem, рестарт сервиса не упустил?)
Хорошо что напомнил, после того как закомментил bind-address при перезагрузке мускула (/etc/init.d/mysql restart) пишет следующий процесс:
"Stopping MySQL database server: mysqld failed!
Starting MySQL database server: mysqld already running."
А как только снимаю "#" с bind-address, перезагрузка идет в нормальном ритме.
Shem вне форума Отправить сообщение для Shem с помощью ICQ Ответить с цитированием
Непрочитано 01.06.2012, 23:51   #4
Супергерой

По умолчанию Re: Debian Mysql

Shem, я думаю ничего страшного не будет, если ты вообще удалишь эту строчку. Хотя да, сам обычно в таких случаях стараюсь комментировать.
Romka вне форума Ответить с цитированием
Непрочитано 01.06.2012, 23:52   #5
Аватар для Mr.Bear
Герой

По умолчанию Re: Debian Mysql

iptables отключили? Права правильно выставили?
__________________
dd if=/dev/zero of=/dev/sdXY
Mr.Bear вне форума Ответить с цитированием
Непрочитано 01.06.2012, 23:55   #6
Аватар для Shem
Пользователь

Автор темы (Топик Стартер) Re: Debian Mysql

Цитата:
Сообщение от RomkaCW Посмотреть сообщение
Shem, я думаю ничего страшного не будет, если ты вообще удалишь эту строчку. Хотя да, сам обычно в таких случаях стараюсь комментировать.
Так что мне делать?

Цитата:
Сообщение от SoBadItsMe Посмотреть сообщение
iptables отключили? Права правильно выставили?
Зачем отключать iptables? Я добавил в исключения 3306, ну а права на базу конечно все выдал.
Shem вне форума Отправить сообщение для Shem с помощью ICQ Ответить с цитированием
Непрочитано 02.06.2012, 00:01   #7
Супергерой

По умолчанию Re: Debian Mysql

Shem, попробуй просто удалить эту строчку.
Romka вне форума Ответить с цитированием
Непрочитано 02.06.2012, 00:03   #8
Аватар для Shem
Пользователь

Автор темы (Топик Стартер) Re: Debian Mysql

Цитата:
Сообщение от RomkaCW Посмотреть сообщение
Shem, попробуй просто удалить эту строчку.
Удалил, все равно "mysqld failed!"
Shem вне форума Отправить сообщение для Shem с помощью ICQ Ответить с цитированием
Непрочитано 02.06.2012, 00:04   #9
Супергерой

По умолчанию Re: Debian Mysql

Shem, ок, скинь весь конфиг сюда, вместе с этой строчкой. Естественно не забудь удалить персональные данные, если есть.
Стоп... Провдуплял...
"Stopping MySQL database server: mysqld failed!
Starting MySQL database server: mysqld already running."
Это говорит что мускул то уже пашет. Попробуй удалить строчку и перезагрузить сам сервер.
Romka вне форума Ответить с цитированием
Непрочитано 02.06.2012, 00:06   #10
Аватар для Shem
Пользователь

Автор темы (Топик Стартер) Re: Debian Mysql

Цитата:
Сообщение от RomkaCW Посмотреть сообщение
Shem, ок, скинь весь конфиг сюда, вместе с этой строчкой. Естественно не забудь удалить персональные данные, если есть.
Стоп... Провдуплял...
"Stopping MySQL database server: mysqld failed!
Starting MySQL database server: mysqld already running."
Это говорит что мускул то уже пашет. Попробуй удалить строчку и перезагрузить сам сервер.
Так тут без разницы, все равно "failed!"

Добавлено через 59 секунд
Вот сам файл:


#
# The MySQL database server configuration file.
#
# You can copy this to one of:
# - "/etc/mysql/my.cnf" to set global options,
# - "~/.my.cnf" to set user-specific options.
#
# One can use all long options that the program supports.
# Run program with --help to get a list of available options and with
# --print-defaults to see which it would actually understand and use.
#
# For explanations see
# http://dev.mysql.com/doc/mysql/en/se...variables.html

# This will be passed to all mysql clients
# It has been reported that passwords should be enclosed with ticks/quotes
# escpecially if they contain "#" chars...
# Remember to edit /etc/mysql/debian.cnf when changing the socket location.
[client]
port = 3306
socket = /var/run/mysqld/mysqld.sock

# Here is entries for some specific programs
# The following values assume you have at least 32M ram

# This was formally known as [safe_mysqld]. Both versions are currently parsed.
[mysqld_safe]
socket = /var/run/mysqld/mysqld.sock
nice = 0

[mysqld]
#
# * Basic Settings
#
user = mysql
pid-file = /var/run/mysqld/mysqld.pid
socket = /var/run/mysqld/mysqld.sock
port = 3306
basedir = /usr
datadir = /var/lib/mysql
tmpdir = /tmp
language = /usr/share/mysql/english
skip-external-locking
#
# Instead of skip-networking the default is now to listen only on
# localhost which is more compatible and is not less secure.
bind-address 127.0.0.1
#
# * Fine Tuning
#
key_buffer = 16M
max_allowed_packet = 16M
thread_stack = 192K
thread_cache_size = 8
# This replaces the startup script and checks MyISAM tables if needed
# the first time they are touched
myisam-recover = BACKUP
#max_connections = 100
#table_cache = 64
#thread_concurrency = 10
#
# * Query Cache Configuration
#
query_cache_limit = 1M
query_cache_size = 16M
#
# * Logging and Replication
#
# Both location gets rotated by the cronjob.
# Be aware that this log type is a performance killer.
# As of 5.1 you can enable the log at runtime!
#general_log_file = /var/log/mysql/mysql.log
#general_log = 1
#
# Error logging goes to syslog due to /etc/mysql/conf.d/mysqld_safe_syslog.cnf.
#
# Here you can see queries with especially long duration
#log_slow_queries = /var/log/mysql/mysql-slow.log
#long_query_time = 2
#log-queries-not-using-indexes
#
# The following can be used as easy to replay backup logs or for replication.
# note: if you are setting up a replication slave, see README.Debian about
# other settings you may need to change.
#server-id = 1
#log_bin = /var/log/mysql/mysql-bin.log
expire_logs_days = 10
max_binlog_size = 100M
#binlog_do_db = include_database_name
#binlog_ignore_db = include_database_name
#
# * InnoDB
#
# InnoDB is enabled by default with a 10MB datafile in /var/lib/mysql/.
# Read the manual for more InnoDB related options. There are many!
#
# * Security Features
#
# Read the manual, too, if you want chroot!
# chroot = /var/lib/mysql/
#
# For generating SSL certificates I recommend the OpenSSL GUI "tinyca".
#
# ssl-ca=/etc/mysql/cacert.pem
# ssl-cert=/etc/mysql/server-cert.pem
# ssl-key=/etc/mysql/server-key.pem



[mysqldump]
quick
quote-names
max_allowed_packet = 16M

[mysql]
#no-auto-rehash # faster start of mysql but no tab completition

[isamchk]
key_buffer = 16M

#
# * IMPORTANT: Additional settings that can override those from this file!
# The files must end with '.cnf', otherwise they'll be ignored.
#
!includedir /etc/mysql/conf.d/

Добавлено через 5 минут
На сколько я знаю, можно в поле bind-address вписать вместо "127.0.0.1" -
" 0.0.0.0"

Добавлено через 12 минут
А еще не понятно с какого перепугу, у меня не работает не Putty, не WinSCP хотя вчера все было отлично, даже сборку через WinSCP залил, и через Putty выключил машину.
Порты 22/23/80 открыты...

Последний раз редактировалось Shem; 02.06.2012 в 00:19. Причина: Добавлено сообщение
Shem вне форума Отправить сообщение для Shem с помощью ICQ Ответить с цитированием
Ответ


Здесь присутствуют: 1 (пользователей: 0 , гостей: 1)
 
Опции темы

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.

Быстрый переход

Похожие темы
Тема Автор Раздел Ответов Последнее сообщение
Perfect World сервер 1.3.6 на Debian и MYSQL qANTONq Документация 3 08.01.2012 16:58
mysql и Debian mr.roke Операционные системы / Operating systems 13 09.12.2011 09:10
Debian 6 Andrei1987 Lineage II 16 26.11.2011 22:43
Установка последней версии mysql на Debian Place Lineage II 1 24.10.2011 20:50
mysql DEBIAN ERROR 2002 Литион Операционные системы / Operating systems 2 10.09.2011 08:42


© 2007–2019 «Форум администраторов игровых серверов»
Защита сайта от DDoS атак — StormWall
Работает на Булке неизвестной версии с переводом от zCarot
Текущее время: 13:13. Часовой пояс GMT +3.

Вверх